Beam Benchドキュメント

メニュー

Beam Benchのメニューとコマンド画面の仕組み、および目的の項目の場所について説明します。

Beam Benchのメニュー画面は、従来のCADアプリより簡潔です。主な操作は次の場所にあります。

  1. ホットキー: ホットキーリファレンスを参照してください。レジストリにはカスタマイズ可能なコマンドが150個あり、そのうち85個にはデフォルトのショートカットがあります。
  2. ツールバー: ツールバーを参照してください。作成、モディファイア、プロパティがあります。
  3. パネル: パネルを参照してください。右側のパネルに、コンテキストに応じた操作の大半があります。
  4. コンテキストメニュー: キャンバスまたはレイヤータブを右クリックすると、状況に応じたコマンドにアクセスできます。

アプリには、プラットフォームに応じて、ファイル、編集、表示、ツール、整列、マシン、レーザーツール、ウィンドウ、言語、ヘルプのメニューが表示されます。macOSではネイティブのメニューバーに表示されます。Windows / Linuxではウィンドウ内に表示されます。ウィンドウ内のメニューバーには、表示言語を切り替える言語メニューもあります(下記参照)。

言語メニュー

ウィンドウ内のメニューバーにある言語メニューには、Beam Benchが現在翻訳を提供しているすべてのロケールが一覧表示されます。いずれかを選ぶと、UI言語がすぐに切り替わります。選択はアプリの環境設定に保存され、すべてのパネル、ダイアログ、メニュー、ツールチップに適用されます。

現在のビルドで利用できるロケールは次のとおりです。

  • 英語
  • Deutsch(ドイツ語)
  • Español(スペイン語、スペイン)およびEspañol, Latinoamérica(スペイン語、ラテンアメリカ)
  • Français(フランス語)
  • Italiano(イタリア語)
  • Português, Brasil(ポルトガル語、ブラジル)
  • Nederlands(オランダ語)
  • Polski(ポーランド語)
  • Čeština(チェコ語)
  • Svenska(スウェーデン語)、Norsk bokmål(ノルウェー語ブークモール)、Dansk(デンマーク語)、Suomi(フィンランド語)
  • Magyar(ハンガリー語)
  • Türkçe(トルコ語)
  • Ελληνικά(ギリシャ語)
  • Русский(ロシア語)
  • Slovenščina(スロベニア語)
  • 日本語
  • 한국어(韓国語)
  • 简体中文(簡体字中国語)および繁體中文(繁体字中国語)

デフォルトは英語です。ロケールに文字列がない場合、その文字列はロケールが更新されるまで英語にフォールバックします。

コマンドレジストリ

Beam Benchでは内部的に、すべての操作がコマンドです。コマンドレジストリには、それぞれのメタデータ(ID、ラベル、カテゴリ、デフォルトのホットキー、ホットキーを編集できるかどうか)が保存されます。設定のショートカットタブとスタンドアロンのホットキーエディターから、このレジストリを利用できます。

カテゴリの一覧は次のとおりです。

  • ファイル: 新規、開く、保存、インポート、エクスポート、印刷。
  • 編集: 元に戻す / やり直す、クリップボード、選択、変換。
  • ツール: すべてのキャンバスツール(選択、描画、長方形、楕円、...)。
  • 整列: グループ化 / グループ化解除、Z順、反転 / 回転、整列、ジョグ。
  • 表示: グリッドとスナップのコントロール。
  • ウィンドウ: プレビュー、ズーム、サイドパネル。
  • レーザーツール: 素材 / フォーカス / 間隔のテスト。
  • 環境設定: 設定、ホットキーエディター。
  • アプリ: 終了。
  • ヘルプ: クイックヘルプ。

完全な表はホットキーリファレンスを参照してください。

コンテキストメニュー

キャンバスの右クリック

キャンバスを右クリックすると(選択範囲の有無にかかわらず)、最も関連性の高い操作を含むコンテキストメニューが開きます。

  • コピー / 貼り付け / 複製 / 削除。
  • グループ化 / グループ化解除。
  • ブール演算(2つ以上の図形を選択した場合)。
  • カット / トレース / 画像を調整(画像を選択した場合)。
  • 整列(整列、分布、順序、反転、回転)。
  • ロック / ロック解除。

レイヤータブの右クリック

レイヤータブを右クリックすると、選択範囲をこのレイヤーに移動など、レイヤー固有の操作が開きます。Shiftを押しながら右クリックすると、そのレイヤーのオブジェクトがキャンバス上で点滅します。

レイヤーストリップの右クリック

レイヤータブストリップの空白部分を右クリックすると、すべてのレイヤーに対する一括操作が開きます。レイヤーの有効化、無効化、出力の反転、表示、非表示、表示の反転、カットを最後に並べ替える操作などがあります。

コマンドを検索する

コマンドを見つける最も速い方法はホットキーリファレンスの表です。カテゴリ別にデフォルトのキーボードショートカットとともにすべてが一覧表示されています。

カスタマイズするには、設定 → ショートカットを開くか、スタンドアロンのホットキーエディターを使用します。検索ボックスでは、ラベル、グループ、ID、またはショートカットでコマンドを絞り込めます。

関連項目

On this page